1035 Password

题目

To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1 (one) from l (L in lowercase), or 0 (zero) from O (o in uppercase). One solution is to replace 1 (one) by @, 0 (zero) by %, l by L, and O by o. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.

Output Specification:

For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified where N is the total number of accounts. However, if N is one, you must print There is 1 account and no account is modified instead.

Sample Input 1:

1
2
3
4
3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa

Sample Output 1:

1
2
3
2
Team000002 RLsp%dfa
Team000001 R@spodfa

Sample Input 2:

1
2
1
team110 abcdefg332

Sample Output 2:

1
There is 1 account and no account is modified

Sample Input 3:

1
2
3
2
team110 abcdefg222
team220 abcdefg333

Sample Output 3:

1
There are 2 accounts and no account is modified

题意

让你按照给定的规则修改用户密码,修改完成之后输出修改的结果:

  • 1->@
  • 0->%
  • l->L
  • O->o

如果只有1个账户输入,而没有发生修改,输出:

There is 1 account and no account is modified

如果有N个账户输入,而没有发生修改,输出:

There are N accounts and no account is modified

思路

这道题一开始我还打算用字典来存储用户名和密码,但是搞了好半天还不如直接用两个字符串数组.

创建一个字符串数组users用来存用户名,另一个字符串数组passwords用来存密码,两者位置一一对应

再创建一个存储修改位置的布尔数组modifiedInfo,哪个位置修改了密码,就在对应的布尔数组上置为true,最后做一个循环输出就行了.

代码

先写一个用来修改密码的函数:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
public static string ChangePassword(char[] password)
{
for (int i = 0; i < password.Length; i++)
{
if (password[i] == '0')
{
password[i] = '%';
}
if (password[i] == '1')
{
password[i] = '@';
}
if (password[i] == 'l')
{
password[i] = 'L';
}
if (password[i] == 'O')
{
password[i] = 'o';
}
}
return new string(password);
}
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
public static void Main()
{
int userCount = int.Parse(System.Console.ReadLine());
int modifiedCount = 0;
bool[] modifiedInfo = new bool[userCount];
string[] users = new string[userCount];
string[] passwords = new string[userCount];
for (int i = 0; i < userCount; i++)
{
string[] line = System.Console.ReadLine().Split();
users[i] = line[0];
passwords[i] = line[1];
}
for (int i = 0; i < userCount; i++)
{
if (!(ChangePassword(passwords[i].ToCharArray()) == passwords[i]))
{
//判断旧密码和新密码是否一致.
modifiedInfo[i] = true;
passwords[i] = ChangePassword(passwords[i].ToCharArray());
modifiedCount++;
}
}
if (modifiedCount == 0)
{
if (userCount != 1)
{
Console.WriteLine("There are " + userCount + " accounts and no account is modified");
}
else
{
Console.WriteLine("There is " + userCount + " account and no account is modified");
}
}
else
{
Console.WriteLine(modifiedCount);
for (int i = 0; i < userCount; i++)
{
if (modifiedInfo[i])
{
Console.WriteLine(users[i] + " " + passwords[i]);
}
}
}
}